Obecnie 145 forumowiczów jest online
Obecnie 145 forumowiczów jest online
Przeanalizuj informacje ze swoich raportów i rozwiąż problemy z nimi związane.
Poprowadź mnie
star_border
Odpowiedz

Błędny adres strony w raportach - treść + pagespeed - końcówka adresu

[ Edytowane ]
Nowicjusz ✭

Cześć.

Mam, jak mi się przynajmniej wydaje dobrze skonfigurowane konto Analitycs (pokazuje poprawnie odsłony, userów, czas rzeczywisty, adres strony w ustawieniach jest poprawny). Wszystko wydaje się działać dobrze, ale kiedy przechodzę w raportach np do Analizy Treści , wybieram konkretną podstronę (mam pełne statystyki, wszystko zlicza) i chcę w nią kliknąć to otwiera mi się błędny adres i strona się nie ładuje. 

 

Wszystko przez błędną końcowkę domeny. Zamienia mi moją domenę .do na .pl . Doklejony jest odpowiedni url wpisu lecz przez podmianę domeny nic się nie wczytuje. Podobnie jest w PageSpeed, kiedy klikam na podstronę i otwiera mi się pagespeed mam z wiadomych przyczyn 404.

 

Tak jak wspomniałem - raporty są ok, wczytuje mi dane, wysłany testowy ruch otwiera odpowiednią stronę, raport w czasie rzeczywistym działa. Zastanawiam się, skąd ten błąd i jak to naprawić. No i czy coś takiego może mieć wpływ na ewentualne złe liczenie statystyk?

 

Przeszukałem forum, internet i nie znalazłem odpowiedzi na to pytanie. Będę wdzięczny za pomoc. Dzięki

 

PS Błąd miałem zarówno kiedy miałem podpięty kod bezpośrednio z GA, jak i teraz kiedy założyłem konto na tag managerze (myślałem, że to pomoże w rozwiązaniu ale jest to samo).

Odpowiedź eksperta 1verified_user

Zaakceptowane rozwiązania
Zaakceptowane rozwiązanie.
Rozwiązanie
Zaakceptowane przez autora tematu: Daniel K
2 tygodni(e) temu

Błędny adres strony w raportach - treść + pagespeed - końcówka adresu

Najlepszy Współtwórca

Sprawdź jeszcze ustawienia widoku.

Dominik Myślak

Wyświetl rozwiązanie w oryginalnym poście


Wszystkie odpowiedzi

Błędny adres strony w raportach - treść + pagespeed - końcówka adresu

Najlepszy Współtwórca

Z tego co piszesz to problem występuje dopiero jak chcesz przejść na swoją stronę. Raporty w Analytics zbierają się poprawnie i widzisz tam podstrony z odpowiednimi aliasami?

 

Może na stronie masz jakieś przekierowanie, które rozpoznaje język, adres ip i usiłuje Cię przekierować na polską wersję?

Dominik Myślak

Błędny adres strony w raportach - treść + pagespeed - końcówka adresu

Nowicjusz ✭

Dzięki za odpowiedź. Zgadza się, raporty pokazują mi dokładne podstrony, kategorie, generalnie urle. Mam odsłony, czas, userów, czas rzeczywisty pokazuje mi odpowiednie podstrony (jak otworzę jakąś podstronę to po 3-4 sekundach pojawia mi się w czasie rzeczywistym).

 

Strona nie ma żadnych przekierowań, przynajmniej nic takiego nie robiłem świadomie. Korzystanie z witryny nie przekierowuje nigdzie, tym bardziej na adres .pl . W źródle strony nigdzie nie występuje adres .pl, przeklikałem całego wordpressa i nigdzie nie wpisałem tam tego adresu .pl. Może problemem jest jakieś nierozpoznawanie przez Analitycs domeny .do? W sensie koncówki, moze jest mało "popularna"? Na razie tylko to mi przyszło do głowy.

 

Kiedy ręcznie wkleję podstronę czy stronę główną do pagespeed to raport generowany jest poprawnie. Kiedy wejdę do GA i w tą samą podstronę z poziomu ga kliknę to podmienia mi adres z .do na .pl no i jest 404. 

 

W ustawieniach analitycsa - Ustawienia usługi -> Domyślny URL wpisany jest poprawny adres z końcówką .do. Poniżej liczba działań w usłudze pokazuje mi wartości liczbowe - zatem działa. 

 

Czy jeszcze gdzieś w GA ustawia się adres strony? 

Zaakceptowane rozwiązanie.
Rozwiązanie
Zaakceptowane przez autora tematu: Daniel K
2 tygodni(e) temu

Błędny adres strony w raportach - treść + pagespeed - końcówka adresu

Najlepszy Współtwórca

Sprawdź jeszcze ustawienia widoku.

Dominik Myślak

Błędny adres strony w raportach - treść + pagespeed - końcówka adresu

Nowicjusz ✭

Był tam .pl! Dzięki wielkie. Czy uważasz, że miało to wpływ na zliczanie statystyk, czy odnosiło się to tylko do widoku - zatem "widziałem" zły adres, ale zliczanie było poprawne?