Obecnie 288 forumowiczów jest online
Obecnie 288 forumowiczów jest online
Poprowadź mnie
star_border
Odpowiedz

HTTP response code indicates tag failed to fire: Status 404.

Student ✭ ✭ ✭

Od kilku dni miałem problem z prawidłowym działaniem GTM z powodu błędu 404. 

Co dziwniejsze, Tag Assistant pokazywał błąd jednie w momencie wyłączenia podglądu w GTM, 

po jego włączeniu wszystko zaczynało działać prawidłowo. Dla pewność sprawdziłem ruch na żywo w GA i wszystko pięknie śmigało. 

 

Przekopałem angielski internet i udało mi się odszukać kilka rozwiązań, jedno z nich pomogło mi uporać się z problemem. 

Pomyślałem, że podzielę się z wami tym co znalazłem, może komuś przyoszczędzi to czas przy "odkrywaniu koła na nowo" Emotikon: Mrugający

 

To co znalazłem w sieci:

 

1. Zainstalować w GTM więcej niż 1 kontener, w moim przypadku pierwotnie był zainstalowany jednie GA, gdy dorzuciłem do tego kontener z Yandex Metrica wszystko pięknie zagrało i mój problem się rozwiązał. 

2. Można też stworzyć szablon potomny i wgrać w niego jedynie "nagłówek" z kodem GTM. Podobno działa, nie próbowałem jednak tej metody. 

3. Instalacja nowego kontenera GTM - w moim przypadku to nie pomogło.

 

Jeśli znacie jakieś inne rozwiązania problemu z 404 w Tag Assistancie piszcie Emotikon: Szczęśliwy 

Odpowiedź eksperta 1verified_user

Zaakceptowane rozwiązania
Zaakceptowane rozwiązanie.
Rozwiązanie
Zaakceptowane przez: Adam Grabowski (Wschodząca Gwiazda)
wrzesień

HTTP response code indicates tag failed to fire: Status 404.

Wschodząca Gwiazda

Taki błąd, o którym piszesz, raportowany jest przez Tag Assistant wówczas, gdy nie masz opublikowanych żadnych tagów w GTM - czyli po świeżej instalacji kodu nowego kontenera na stronie.

Gdy dodałeś już jakieś tagi, ale jeszcze ich nie opublikowałeś, to w trybie podglądu błędu oczywiście nie było, bo wtyczka widziała tagi, ale po wyjściu z trybu podglądu znów wracał błąd, bo kontener znów był widziany jako pusty.

Dopiero po opublikowaniu pierwszego tagu błąd znika.

Nie musi być kilka tagów - wystarczy jeden jakikolwiek tag, byle kontener nie był pusty i oczywiście musi zostać opublikowany.

Tomasz Ciepłucha

Wyświetl rozwiązanie w oryginalnym poście


Wszystkie odpowiedzi
Zaakceptowane rozwiązanie.
Rozwiązanie
Zaakceptowane przez: Adam Grabowski (Wschodząca Gwiazda)
wrzesień

HTTP response code indicates tag failed to fire: Status 404.

Wschodząca Gwiazda

Taki błąd, o którym piszesz, raportowany jest przez Tag Assistant wówczas, gdy nie masz opublikowanych żadnych tagów w GTM - czyli po świeżej instalacji kodu nowego kontenera na stronie.

Gdy dodałeś już jakieś tagi, ale jeszcze ich nie opublikowałeś, to w trybie podglądu błędu oczywiście nie było, bo wtyczka widziała tagi, ale po wyjściu z trybu podglądu znów wracał błąd, bo kontener znów był widziany jako pusty.

Dopiero po opublikowaniu pierwszego tagu błąd znika.

Nie musi być kilka tagów - wystarczy jeden jakikolwiek tag, byle kontener nie był pusty i oczywiście musi zostać opublikowany.

Tomasz Ciepłucha